#amazon(4844319736)

#adsense(728x90)

 

レイヤ 2 スイッチング[edit]

エラー チェック方式[edit]

タイプ説明特徴その他
ストア アンド フォワードFCSまですべてチェックエラー チェックも行うが遅いほとんどの Catalyst で採用
フラグメント フリー64byte だけチェックちょうどいいCatalyst 1900 でデフォルト
カット スルー6byte (宛先 MAC アドレス) だけチェック何もしないので早い

CAM [Content Addressable Memory][edit]

概要[edit]

設定[edit]

確認[edit]

TCAM [Ternary Content Addressable Memory][edit]

概要[edit]

確認[edit]

インターフェース[edit]

設定[edit]

エラー検知[edit]

  1. 自動回復
    sw(config)# errdisable recovery cause cause
    
    • cause
      • dhcp-rate-limit …
      • dtp-flap …
      • gbic-invalid …
      • link-flap …
      • loopback …
      • pagp-flap …
      • sfp-config-mismatch …
      • psecure-violation …
      • security-violation …
      • channel-misconfig …
      • bpduguard … BPDU Guard による無効化
      • storm-control …
      • udld … UDLD による無効化
      • unicast-flood …
      • vmps …
      • all … 上記全て
  2. 自動回復までの時間
    sw(config)# errdisable recovery interval time
    
    • time
      • 30~86,400 (デフォルトは 300 秒)

確認[edit]

サマリ情報[edit]

sw# show interface status

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1     ### aaaa ###       connected    10         a-full  a-100 10/100BaseTX
Fa0/2     ### bbbb ###       disabled     10           auto   auto 10/100BaseTX
Fa0/3     ### cccc ###       disabled     10           auto   auto 10/100BaseTX
Fa0/4     ### dddd ###       disabled     10           auto   auto 10/100BaseTX

エラー原因[edit]

sw# show interface status err-disabled

EC [Ether Channel][edit]

概要[edit]

[Host1]───[Switch1]===[Switch2]───[Host2]

設定[edit]

  1. I/F の選択
    sw1(config)# interface type mod/num enter.png
    
  2. チャネルの作成
    sw1(config-if)# channel-group num mode mode enter.png
    Creating a port-channel interface Port-channel 1
    
    • mode
      • desirable … PAgP を送信して、チャネルを試みる
      • auto … PAgP を受信した場合、チャネルする
      • active … LACP を送信して、チャネルを試みる
      • passive … LACP を受信した場合、チャネルする
      • on … ネゴシエーション プロトコルを使用しないで、チャネルする
      • off … チャネルしない

ロードバランシングの設定[edit]

sw(config)# port-channel load-balance method enter.png
methodハッシュ演算説明
src-ipbits
dst-ipbits
src-dst-ipXOR
src-macXORデフォルト
dst-macbits
src-dst-macbits
src-portXORCat. 4500 以上
dst-portbitsCat. 4500 以上
src-dst-portbitsCat. 4500 以上

プロトコルの変更[edit]

sw(config)# interface port-channel num
sw(config-if)# channel-protocol protocol enter.png

確認[edit]

sw00# show etherchannel
                Channel-group listing:
                ----------------------

Group: 1 チャンネル番号
----------
Group state = L2
Ports: 2   Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol:   PAgP

SPAN [Switched Port Analyzer][edit]

概要[edit]

設定[edit]

sw(config)# monitor session session_id source interface type mod/num
sw(config)# monitor session session_id destination interface type mod/num

ポート セキュリティ[edit]

概要[edit]

設定[edit]

  1. ポート セキュリティはダイナミック ポート、Ether Channel では使用できない
    sw(config)# interface type mod/num
    sw(config-if)# switchport mode access|trunk
    
    • 2950 はアクセス ポートのみ
    • 2960、3560 はトランク ポートも可能
  2. ポート セキュリティを設定
    sw(config-if)# switchport port-security
    
  3. 最大接続数で制限する場合
    sw(config-if)# switchport port-security maximum max
    
    • max
      • MAC アドレスの最大接続数 (1~132)
      • デフォルトは 1
  4. MAC アドレスで制限する場合
    sw(config-if)# switchport port-security mac-address mac-addr
    
    • mac-addr
      • 通信を許可する MAC アドレス
  5. 違反時の動作
    sw(config-if)# switchport port-security violation type
    
    • type
      • shutdown … I/F をシャットダウンする (デフォルト)
      • protect … 違反アドレスからのフレームを破棄する
      • restrict … protect の動作に加え、SNMP Trap を送信し、違反カウンタを上げる

MAC アドレスの保存[edit]

MAC アドレスのエージング[edit]

  1. エージング時間
    sw(config-if)# switchport port-security aging time time
    
    • time
      • 消去するまでの時間
      • 0~1,440 分 (デフォルトは 0、エージ アウトしない)
  2. エージング タイプ
    sw(config-if)# switchport port-security aging type type
    
    • type
      • absolute … 学習してから一定時間で消去する (デフォルト)
      • inactivity … 通信が終了してから一定時間で消去する
  3. スタティック設定にも適用
    sw(config-if)# switchport port-security aging static
    

確認[edit]

IEEE 802.1x[edit]

概要[edit]

設定[edit]

  1. AAA の有効化
    sw(config)# aaa new-model
    
  2. 認証リストの作成
    sw(config)# aaa authentication dot1x default group radius
    
    • 802.1x では、default と group radius のみサポート
  3. 802.1x の有効化
    sw(config)# dot1x system-auth-control
    
  4. IP アドレス
    sw(config)# radius-server host ip-addr
    
  5. 共通鍵
    sw(config)# radius-server key key
    
  6. I/F の選択
    sw(config)# interface type mod/num
    sw(config-if)# switchport mode access
    
  7. 802.1x の有効化
    sw(config-if)# do1x port-control mode
    
    • mode
      • auto … IEEE 802.1x 認証を有効にする
      • force-authorized … IEEE 802.1x 認証を無効にする (デフォルト)
      • force-unauthorized … IEEE 802.1x 認証を無効にして、無許可ステータスにする

マルチ ホスト モード[edit]

再認証[edit]

  1. 再認証の有効化
    sw(config-if)# dot1x reauthentication
    
  2. 認証間隔
    sw(config-if)# dot1x timeout reauth-period time
    
    • time
      • 再認証を行う間隔
      • 1~65535 秒 (デフォルトは X 秒)
  1. 手動での再認証
    sw# dot1x re-authenticate interface type mod/num
    

ゲスト VLAN[edit]

  1. VLAN 番号
    sw(config-if)# dot1x guest-vlan vlan-id
    

制限付き VLAN[edit]

  1. VLAN 番号
    sw(config-if)# dot1x auth-fail vlan vlan-id
    

クリティカル VLAN[edit]

  1. VLAN 番号
    sw(config-if)# dot1x critical vlan vlan-id
    
  2. RADIUS サーバ復旧後に再認証を行う
    sw(config-if)# dot1x critical recovery action reinitialize
    

PoE [Power of Ethernet][edit]

概要[edit]

  1. 初期状態
    • Link Down の場合は電力供給は無効
  2. Link Up
    • スイッチは 340 kHz のテスト トーンを送信する
    • PoE 対応デバイスが接続されていた場合は、テスト トーンがループバックされる
  3. 電力供給開始
    • UTP ケーブルに対して 15 W (48 V, 0.37 A) の電力を供給する
    • デバイスが起動する
  4. 電力調整
    • Cisco IP 電話の場合、CDP で必要な電力をスイッチに伝える
    • スイッチは供給電力を変更する

設定[edit]

Multi Layer Switch[edit]

┏━━━━━━━━━━━━━━┓
─[0/ 1]┐            ┌[0/ 4]─
─[0/ 2]┼─[Switch]─┼[0/ 5]─
─[0/ 3]┘     │     └[0/ 6]─
─[0/14]──[Router]──[0/15]─
─[0/ 7]┐     │     ┌[0/10]─
─[0/ 8]┼─[Switch]─┼[0/11]─
─[0/ 9]┘            └[0/13]─
┗━━━━━━━━━━━━━━┛

ルーティングの有効化[edit]

sw(config)# ip routing

L2 ポートの設定[edit]

sw(config)# interface type mod/num enter.png
sw(config-if)# switchport enter.png

L3 ポートの設定[edit]

sw(config)# interface type mod/num enter.png
sw(config-if)# no switchport enter.png
sw(config-if)# ip address ip_addr netmask

SVI [Switched Virtual Interface][edit]

  1. VLAN への IP アドレスの設定
    sw(config)# interface vlan id
    sw(config-if)# ip address ip_addr netmask
    

SLB [Server Load Balancing][edit]

サーバの設定[edit]

  1. サーバ ファームの作成
    sw(config)# ip slb serverfarm name
    
    • name
      • 1~15 文字
  2. バランシング方法
    sw(config-slb-sfarm)# predictor mode
    
    • mode
      • roundrobin … WRR [Weighted Round Robin] 方式
      • leastconns … WLC [Weighted Least Connections] 方式
  3. バランシング先
    sw(config-slb-sfarm)# real ip-addr
    
    • ip-addr
      • バランシング先サーバの実 IP アドレス
  4. ウェイト
    sw(config-slb-real)# weight weight
    
    • weight
      • サーバが受付可能な接続数
      • 他サーバとの相対的な数
      • 1~255 (デフォルトは 8)
  5. バランシング開始
    sw(config-slb-real)# inservice
    
  1. バランシングからの切り離し
    sw(config-slb-real)# no inservice
    

仮想サーバの設定[edit]

  1. 仮想サーバ
    sw(config)# ip slb vserver name
    
    • name
      • 1~15 文字
  2. サーバ ファームの割り当て
    sw(config-slb-vserver)# serverfarm name
    
    • name
      • バランシング先サーバ ファームの名前
  3. 仮想 IP アドレス
    sw(config-slb-vserver)# virtual ip-addr
    
    • ip-addr
      • 仮想サーバの IP アドレス
  4. アクセス制限 (任意)
    sw(config-slb-vserver)# client ip-addr netmask
    
  5. バランシング開始
    sw(config-slb-vserver)# inservice
    
 

#adsense(728x90)


トップ   編集 凍結 差分 履歴 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2020-07-08 (水) 18:10:14